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12 Cast Unit Drawings 

In this lesson we will learn how to create cast unit drawings of the concrete members of the 
model. We will then modify the drawings and use the finished drawings for cloning. 

In this lesson 

You will learn how to: 

• Use your own Select filters 

• Define cast unit drawing properties 

• Define Drawing Classifier settings 

• Use the Drawing Classifier 

• Use different drawings of the same cast unit 

• Use cloning 

• Use the drawing list 

12.1 Create Cast Unit Drawings 
Cast unit drawings are workshop (or in-situ) drawings, in which details of a cast unit, 
consisting of the concrete parts, reinforcement and components, are presented for fabrication. 

All of the views in the drawings are current views of the members as they are in the model. 
When the model contains any identical members, the drawing is a view of one of these 
members. The drawing, however, contains information about the quantity of all of the 
identical members. If the "host" member of the drawing is modified or deleted, it will get a 
new position mark at the next numbering. Tekla Structures will then automatically assign the 
original drawing to another member with the original position mark. 

Tekla Structures integrates the drawings and reports with the model. This means that, for 
example, dimensions and marks in the drawings are always correct. Because the information 
in the drawings and reports comes directly from the model, you cannot delete any of the parts 
or bolts from the drawings. You are able to filter out parts and other objects in the drawings, 
or make them invisible. 

You can create drawings and reports at any stage of the project. If you change the model, 
Tekla Structures updates the related drawings when you next carry out numbering. 

Once the model is numbered it is possible to create cast unit drawings of selected parts in the 
model. Selecting Cast Unit drawings from the Drawing pull-down menu will generate 
drawings of the selected parts. However, to get the drawings appear as complete as possible, 
it is a good idea to create drawings of certain cast units with suitable properties predefined 
for them. 
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There are two options for cast unit drawing specification. The 
possible options to select are By cast unit position or By cast unit 
ID. See more in Tekla Structures Help: Drawing > Getting started 
with drawings > Creating cast unit drawings. 

Define Cast Unit Drawing Properties for Beams 
We will now define cast unit drawing properties for a beam, which has reinforcements 
included. 

1. From the pull-down menu select Properties > Cast unit drawing... Set the common 
drawing 
properties 

 

2. Select By cast unit position as the cast unit definition method. 

3. Type BEAM REINFORCEMENT into the Name field. This text will appear in the 
drawing list. 

We will next define drawings size, layout and view projection. See more in Tekla Structures 
Help: Drawing > Drawing layout > Drawing size and Drawing > Drawing layout > Scale 
and location of drawing views > Location of views in drawings. Look also at lesson 10 for 
layouts. 

Set the layout 
properties 

4. Press Layout… button. 

5. Select Size definition mode to be Autosize. 

6. Select Calculated/fixed sizes in Autosize > Use option menu. 

 

7. Select the Scale tab page. 

8. Set Autoscale to No. 

9. Select the Other tab page. 

10. Select Projection type to be First angle (also referred to as European projection). 

11. Set Yes to Side views beside main. 
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12. Enter the name Beam in the text box next to the Save as button, then click Save as to 
save the settings. 

13. Close the dialog by pressing OK. 

Next we will define which views will be created to the drawing. See more in Tekla 
Structures Help: Drawing > Drawing properties > Drawing view properties. 

Set the view 
properties 

1. Press View… button. 

 

2. Turn back and bottom views off, all other views to on or auto. 

3. Select theAttributes tab.Set Scale to 1:20. All views of a view type share the same 
scale. 

5. Set Coordinate system to local. 

6. Set rotation to 0 in all directions. 

7. Enter the name Beam in the text box next to the Save as button, then click Save as to 
save the settings. 

8. Close the dialog by pressing OK. 

Next we will define how the parts will be represented in the drawing. See more in Tekla 
Structures Help: Drawing > Drawing properties > Drawing view properties. 

Set the part 
properties 

1. Press Part… button. 

2. Set Part representation to Exact. 

3. Set Hidden lines on and Center line and Reference lines off. 

4. Select the Appearance tab. 

5. For Visible lines, select color, which is weighted 0.3 mms. For all other lines, select line 
weight 0.1 mm. 
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Color weight is defined in plotter catalog: File > Catalog > Plotters 
> Modify… > Color table... See more in Tekla Structures Help: 
Printing > The plotter catalog > Color. 

 

6. Enter the name Beam in the text box next to the Save as button, then click Save as to 
save the settings. 

7. Close the dialog by pressing OK. 

Next we will define how the parts will be dimensioned in the drawing. See more in Tekla 
Structures Help: Drawing > Dimensioning. 

Set the 
dimensioning 
properties 

1. Press Dimensioning… button. 

2. Set Number of views > Minimize and Combine dimensions > Options to No. 
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3. Select the Part dimensions tab page. 

4. Set part dimensions as below: 

 

5. Select the Position dimensions tab page. 

6. Set Position to Main part. 

7. Enter the name Beam in the text box next to the Save as button, then click Save as to 
save the settings. 

8. Close the dialog by pressing OK. 
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Next we will define how the reinforcements will be represented in the drawing. See more in 
Tekla Structures Help: Drawing > Drawing properties > Reinforcement in drawings. 

Set the 
reinforcing 
properties 

1. Press Reinforcement… button. 

2. Set the Visibility of all reinforcing bars to Visible. 

3. Set the Representation to single line. 

4. Set the Visibility of reinforcing bars in group to all. 

 

5. Select the Bar appearance tab page. 

6. Select color, which is weighted 0.3 mms. Color weight is defined in plotter catalog: File 
> Catalog > Plotters >Modify…> Color table... See more in Tekla Structures Help: 
Printing > The plotter catalog > Color. We will first represent all reinforcements with 
same color and modify it later. 

7. Enter the name Beam in the text box next to the Save as button, then click Save as to 
save the settings. 

8. Close the dialog by pressing OK. 

9. All other object can use standard settings. Now save these settings. Enter the name 
Beam-Reinforcement in the text box next to the Save as button, then click Save as to 
save the settings. Apply all setting and close the dialog by pressing OK. 
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Create a Cast Unit Drawings for a Beam 
We will first create one cast unit drawing for a beam, which has reinforcements included, 
using the predefined attribute values. Then we will edit the settings and use them in new 
drawings for other beams with the help of Drawing Classifier. 

1. Select a beam on grid line 1, between lines E and F. Create a cast unit 
drawing 

 

2. Select Drawing > Cast unit drawing from drop-down menu. A cast unit drawing is 
created of the selected beam using the predefined attribute values and it appears in the 
drawing list, which can be opened from Drawing > List… See more about drawing list 
in Tekla Structures Help: Drawings > Getting started with drawings > Drawing list 
and Lesson 10. 
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Select the drawing from the list and press Open button. Tekla Structures opens the Beam 
reinforcement drawing for editing. You can edit drawings in the Drawing Editor on three 
levels: 

Open the cast unit 
drawing for 
editing 

• Drawing properties 

• View properties 

• Object properties 

For more information about the drawing properties and different drawing levels, see Tekla 
Structures help: 

Help: Drawing > Introduction to drawings > Three levels of editing drawings 

Help: Drawing > Drawing properties and Lesson 10. 

 

Whenever possible, you should modify drawings by editing only 
the drawing properties. Then the modifications remain if the 
drawing must be recreated due to a model change. 

 

Drawing Classifier in Beam Cast Unit Drawings 

Define Drawing Classifier Settings 
We will use Drawing Classifier to represent the different reinforcements with different line 
settings. As a default all reinforcements use the same line settings and for clearer 
representation it is good to show different reinforcement with different line styles and 
weights. 

The Classifier makes use of the Drawing and View Filter, the Drawing and View Properties 
and Property Attribute sub dialogs. See more in Tekla Structures Help: Drawing > Drawing 
Properties > The drawing classifier > Using the classifier. 

To change properties on a single view of a multiple view drawing, edit and save View 
properties rather than Drawing properties. Once the properties have been set up and saved 
they can be applied during automatic drawing creation in the normal ways. 

We will first define the filter settings for different reinforcements. Tekla Structures uses 
filters for selecting objects in drawing views with certain criteria. 

Create view filters 

1. Double click any view border to open the View properties dialog. 

2. Click the Filter... button to open the View filter properties dialog box. 

3. Select the Reinforcing bars tab page. 

4.  Write BOTTOM_BAR TOP_BAR to the Reinforcing bar Name field. Note that there is 
an empty space between the names to separate them. 
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5. Save the filter settings with name Main_Bars in the Save as field. 

6. Write then PNL to the Reinforcing bar Name field. 

7. Enter the name Lifting_Hooks in the text box next to the Save as button, then click 
Save as to save the settings. 

8. Next write STIRRUP to the Reinforcing bar Name field. 

9. Enter the name Stirrups in the text box next to the Save as button, then click Save as 
to save the settings. 

10. Click Cancel to close the dialog box. Do not click Apply or OK, as this will apply the 
current filter to the entire drawing and the Classifier will not work. We have now 
defined three different filters for different kind of reinforcements. 

Next we will define the appearance settings for the reinforcements. Define 
reinforcement 
appearance 1. Click the Reinforcement... button to open the View reinforcing bar properties dialog 

box. 

2. Select the Bar appearance tab page. 

3. Select color, which is weighted 0.5 mms. 

4. Enter the name filter_Beam-Reinforcement_Main_Bars in the text box next to the 
Save as button, then click Save as to save the property file for main bars. 

 

The name consists of three sections. First there must be text "filter", 
then the drawing or view attribute file name – in this case "Beam-
Reinforcement" – (the saved settings of drawing or view main 
dialog), last section is the name of the filter attribute file – in this 
case "Main_Bars". The sections are combined with "_" mark. 

 

5. Next select the Bar content tab page. 

6. Select filled line as the Representation type. 

7. Select straight line as symbol at reinforcement ends. 

8. Enter the name filter_Beam-Reinforcement_Lifting_Hooks in the text box next to the 
Save as button, then click Save as to save the property file for main bars. 
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9. Click Cancel to close the dialog box. We have now drawing classifier settings for main 
reinforcements and lifting hooks, stirrups can use Beam-Reinforcement settings. 

Before modifying the drawing, we will add drawing classifier settings for pullout pictures of 
stirrup reinforcement marks. 

Define 
reinforcement 
mark content 

1. Click the Reinforcement marks… button to open the View reinforcing bar mark 
properties dialog box. 

2. Select the Pullout picture from Available elements list on Single mark tab page. 

 

3. Press the Add> button. Pullout picture dialog opens. 

4. Tick the Dimensions and Bending angle, then press OK. 

5. Select then Group above the Elements in mark list. 

 

6. Repeat steps 2 – 4 to add the Pullout picture for reinforcement group mark. 

7. Enter the name filter_Beam-Reinforcement_Stirrups in the text box next to the Save 
as button, then click Save as to save the property file for stirrup reinforcements. 

8. Then remove all elements from Elements in mark list. 

9. Select Name from Available elements list and press Add> button. 

10. Select Diameter from Available elements list and press Add> button. 
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11. Enter the name filter_Beam-Reinforcement_Lifting_Hooks in the text box next to the 
Save as button, then click Save as to save the property file for lifting hooks. 

12. Click Cancel to close the dialog box. 

Use Drawing Classifier to Edit the Drawing  
Now all drawing classifier settings are ready for use. We will first modify the drawing, 
which is already open. 

1. Close all view dialogs by clicking Cancel. Modify the 
drawing 

2. Double click at any empty space to open the Cast unit drawing properties dialog. 

3. Press Modify. Tekla Structures edits the picture using drawing classifier settings. 

 

Main reinforcement bars are now represented with line weighted 0.5 mms, lifting hooks with 
filled line having name + diameter in the mark, and stirrups have a pullout picture in the 
mark. 

4. Now close the drawing saving it. 

Use the Drawing Classifier to Create New Drawings 
Next we will create new drawings of rest of the concrete beams with the same Drawing 
Classifier settings. 

1. Select Properties > Cast unit drawing… to open the Cast unit drawing properties 
dialog. 

2. Select Beam_Reinforcement drawing settings from pull-down menu list. 

3. Press Load button. 

4. Press OK to apply the settings and to close the dialog. 

5. Select BEAM_CONCRETE select filter. 
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6. Make an area select of the whole model. All concrete beams will be selected. 

7. Select Drawing > Cast unit drawing. Tekla Structures generates cast unit drawings of 
the selected beams using drawing classifier settings for reinforced beams and they 
appear in the drawing list with title BEAM REINFORCEMENT. 

Define Cast Unit Drawing Properties for Columns 
Using the settings for beam cast unit drawing as basis, we will next define drawing settings 
for columns and generate cast unit drawings of them. 

1. Select Properties > Cast unit drawing… from drop-down menu to open the Cast unit 
drawing properties dialog. 

2. Select the Beam-Reinforcement from saved attributes list and press Load. 

3. Change the name field to COLUMN REINFORCEMENT. 

4. Enter the name Column-Reinforcement in the text box next to the Save as button, then 
click Save as to save the settings. 

Next we add elevation dimensioning to dimensioning settings. See more in Tekla Structures 
Help: Drawing > Dimensioning. 

Set the 
dimensioning 
attributes 

1. Press Dimensioning… button. 

2. Select the Beam from saved attributes list and press Load. 

3. Select the Position dimensions tab page. 

4. Set the Elevation dimensions to On. 

5. Enter the name Column-Reinforcement in the text box next to the Save as button, then 
click Save as to save the settings. 

6. Close the dialog by pressing OK. 

7. All other object can use standard or Beam-reinforcement settings. Now save these 
settings by pressing Save as in the main dialog. Apply all setting and close the dialog 
by pressing OK. 

Create Cast Unit Drawings for Columns 
1. We will first create one cast unit drawing for a column, which has reinforcements 

included, using the predefined attribute values. Then we will modify the settings and use 
them in new drawings for other beams with the help of drawing classifier. 

2. Select a column on grid lines 1 and C intersection. 

3. Select Drawing > Cast unit drawing from drop-down menu. A cast unit drawing is 
created of the selected column. 

We will next modify the Drawing Classifier settings for columns: Modify the 
Drawing Classifier 
settings 1. Open the column cast unit drawing. 

2. Double click at any view border to open the View properties dialog box. 

3. Open the Reinforcement properties dialog by pressing Reinforcement… 

4. Select filter_Beam-Reinforcement_Main_Bars from pull-down list and press the Load 
button. 

5. Enter the name filter_Column-Reinforcement_Main_Bars in the text box next to the 
Save as button, then click Save as to save the settings. 
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6. Then load the settings of filter_Beam-Reinforcement_Lifting_Hooks. 

7. Enter the name filter_Column-Reinforcement_ Lifting_Hooks in the text box next to 
the Save as button, then click Save as to save the settings. 

8. Click Cancel to close the dialog box. 

We will next add part mark settings for column shoes. First we need to define the filter for 
components. 

1. In View properties dialog, press Filter… 

2. As all parts inside the components have class number 100, we can use that for filtering. 
Enter 100 into Class field on Parts tab page. 

3. Enter the name component in the text box next to the Save as button, then click Save 
as to save the settings. 

4. Click Cancel to close the dialog box. 

5. Next we will define part mark settings for Drawing Classifier, using the component 
filter. 

6. In View properties dialog, press Part mark… 

7. Remove all elements from Elements in mark list, both for main part and secondary part. 

8. Enter the name filter_Column-Reinforcement_component in the text box next to the 
Save as button, then click Save as to save the settings. 

 

9. Click Cancel to close the dialog box. 

10. Double click at any empty space to open the Cast unit drawing properties dialog. 

11. Press Modify. Tekla Structures edits the picture using drawing classifier settings. 

12. Close the drawing and save it. 

We will now create cast unit drawings for all concrete columns with the drawing classifier 
settings. 

Use Drawing 
Classifier to 
create new 
drawings 1. Select COLUMN_CONCRETE select filter. 
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2. Make an area select of the whole model. All concrete columns will be selected. 

3. Select Drawing > Cast unit drawing. Tekla Structures generates cast unit drawings of 
the selected beams using drawing classifier settings for reinforced beams and they 
appear in the drawing list with title COLUMN REINFORCEMENT. 

Create Additional Cast Unit Drawings 
You can create two or more cast unit drawings from the same cast unit. Drawing might be 
produced as three separate smaller size drawings i.e. One including main geometry + 
embeddings + dimension lines, one having Reinforcement, another Surface finishing (tiles 
etc.). 

 

Alternatively, you can add several new views from the same cast 
unit to an existing drawing using Create > View > Basic > Front, 
Up, Back or Down commands. 

 

First we need to define the drawing settings. Set the drawing 
attributes 

1. Select Properties > Cast unit drawing… from drop-down menu to open the Cast unit 
drawing properties dialog. 

2. Select the Column-Reinforcement from saved attributes list and press Load. 

3. Change the name field to COLUMN DIMENSIONS. 

 

4. Enter number 2 to the Sheet number field. 

 

Every additional cast unit drawing of the same cast unit must have 
a different sheet number. 

 

5. Enter the name Column-Dimensions in the text box next to the Save as button, then 
click Save as to save the settings. 

6. Press Reinforcement… button. 

7. Set the visibility of reinforcing bars to Not visible. 

8. Enter the name Column-Dimensions in the text box next to the Save as button, then 
click Save as to save the settings. 

9. Close the dialog by pressing OK. 

10. Now save these settings by pressing Save as in the main dialog. Apply all setting and 
close the dialog by pressing OK. 
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We will now create a dimensioning drawing of one column. Generate an 
additional cast 
unit drawing 1. Select a column on grid lines 1 and C intersection. 

2. Select Drawing > Cast unit drawing from drop-down menu. A cast unit drawing is 
created of the selected column. The drawing appears in the drawing list with title 
COLUMN DIMENSIONS. The drawing name has a new sheet number. 

We will next edit the dimensioning drawing and add there also details for connecting parts. 
For this create basic views of them by selecting part and right-click > Create view > Part 
basic views. 

Edit the additional 
cast unit drawing 

1. Open the cast unit drawing. 

2. We will first add running dimensions for corbel. Double click the Create x dimension 
icon to open the dialog. 

3. Select straight dimensioning to option, which has running dimensions. 

4. On Appearance tab select arrow shape to be filled arrow. 

 

5. Press OK. 

6. Click the corner points of the column and the corbel, end with middle button. 
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7. Next add part mark for bearing pad. 

8. Select the bearing pad. 

9. Right-click > Part mark. 

10. Double click the part mark to open the Part mark properties dialog. 

11. Remove all elements from Elements in mark list. 

12. Add Name and Material to Elements in mark list. 

13. Select the elements and press <Add frame. 

 

14. Press Modify. 
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15. We will now add part basic views to the drawing to show the connecting structures. 

16. In Create pulldown menu select View > From model > View. 

17. Select the Part end view of the pad footing. Tekla Structures generates a new view to 
the drawing. 

18. Right click at any empty space and select Place views command. The views are 
rearranged in the drawing. 

19. Remove unnecessary part marks from the view by selecting them and by pressing Delete 
button. 

20. Double click the view border and select Part. 

21. Set hidden lines visible and press Modify. 

 

22. Add needed dimensions using dimensioning tools. 

23. Close the drawing saving it. 

Cloning Drawings 
We will next clone the additional cast unit drawing for columns on grid line F. You can 
clone drawings to produce cast unit drawings of same or similar cast units. 

You should consider cloning drawings when: 

1. There are several almost similar parts or cast units in the model. 

2. You need to produce several cast unit drawings of same cast unit. 

3. The drawings need a lot of manual editing. 

 See more about cloning in Tekla Structures Help: Drawing > Getting started with 
drawings > Drawing reference > Drawing>Clone drawing. 

Steps to clone drawings: 

1. Finalize, save, and close the drawing you want to clone. 
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2. In the model, select cast units to include in the drawing. 

3. Click Drawing > List... to open the drawing list. 

4. Select the finalized drawing on the drawing list. 

5. Click Clone... 

 

6. In the Drawing cloning dialog box, select the drawing objects in the finalized drawing 
that you want to copy into the new drawing. If you want Tekla Structures to red circle 
the dimensions for which it cannot find a reference point on a part, select the Indicate 
dimension points that need checking checkbox. 

7. Click Clone selected. 

 

Always check dimensions and drawing view sizes in cloned 
drawings. 

 

You can have Tekla Structures to indicate the dimension points that need to be checked. 
Select the checkbox Indicate dimension points that need checking in the Drawing cloning 
dialog box. Tekla Structures circles in red the dimensions for which it cannot find a reference 
point on a part. To remove the red circles in cloned drawings, do one of the following: 

• To remove one circle, in the Drawing Editor, click Edit > Remove dimension point 
circle > Single circle and select the circle to remove. 

• To remove all circles, click Edit > Remove dimension point circle > All. 

Create a new dimension point (Edit > Add dimension point) at the correct position and 
delete the existing dimension point (Edit > Remove dimension point). 

When you delete incorrect dimensions the red circles will also disappear. You can then 
recreate the dimensions. 

 

In order to add and remove dimension points and to remove 
dimension point circles, you may have to adjust the drawing view 
size so that the dimension points are inside the view. 
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