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11 Assembly and Single Part 
Drawings 

We will introduce the creation of assembly and single-part drawings in Tekla 
Structures. 

In this lesson 

We will first create single-part and assembly drawings by using predefined drawing 
wizards (drawing wizards are an automatic way of creating single, assembly and 
multi-drawings). 

We will then edit the drawing properties and create a new drawing wizard. The 
Drawing Wizard will use the edited drawing properties and the select filters that we 
defined in an earlier lesson. Then we will show how the same drawings can be 
created manually. We will also demonstrate how updating effects the drawings. 

Revision control of all drawing types is presented in Lesson 10 Principles of 
working with drawings. 

11.1 Integration between Drawings and the 
Model 

Assembly and Single-Part Drawings 
Single-part drawings are workshop drawings of each of the individual steel parts in 
the model. Assembly drawings are workshop drawings, in which details of an 
assembly consisting of the steel parts are presented for fabrication. 

All of the views in single-part or assembly drawings are current views of the 
members as they are in the model. 

When the model contains any identical members, the drawing is a view of one of 
these members. The drawing, however, contains information about the quantity of 
all of the identical members. If the "host" member of the drawing is modified or 
deleted, it will get a new position mark at the next numbering. Tekla Structures will 
then automatically assign the original drawing to another member with the original 
position mark. 
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Tekla Structures integrates the drawings and reports with the model. This means 
that, for example, dimensions and marks in the drawings are always correct. 
Because the information in the drawings and reports comes directly from the model, 
you cannot delete any of the parts or bolts from the drawings. You are able to filter 
out parts and bolts in the drawings, or make them invisible. 

You can create drawings and reports at any stage of the project. If you change the 
model, Tekla Structures updates the related drawings when you next carry out 
numbering. 

For more information, see Help: Drawing > Introduction to drawings > Basics. 

11.2 Create Drawings Using Drawing 
Wizards 

Once you have numbered the model, you can create assembly and single-part 
drawings from the model. Drawing wizards are the most effective way to create 
drawings in Tekla Structures. 

Wizards automatically produce different types of drawings of different parts, such as 
beams, columns, and braces. You can use wizards to create single-part, assembly, or 
multi-drawings using the settings defined in the wizard files. 

You can use the predefined wizard files, edit them, or create your own drawing 
wizards. The Wizard dialog box lists the available wizard files. 

 

For more information on drawing wizards, see: 
Help: Drawing > Getting started with drawings > Using drawing wizards 

Help: Drawing > Getting started with drawings > Drawings reference > File > 
Wizard… 

 

Drawing wizards cannot be used to create cast unit (CU) 
drawings of concrete structures. 
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Functionality of Drawing Wizards 
For each member type in the model, drawing wizards automatically perform the 
following steps: 
1. Define the drawing type to be created (single, assembly or multi). 

2. Define the drawing properties to be used. 

3. With the given select filter, select the parts from which to create drawings. 

4. Create drawings. 

When you apply a wizard, you can choose whether the wizard creates drawings from 
all parts of the model, or just from the selected parts. 

 

By creating wizards that match the select filters and drawing 
properties in the project you can automatically create all 
single and assembly drawings of the parts using the correct 
predefined properties. 

 

 

Preconditions of using a drawing wizard: 

• Numbering of the model must be up to date. 

• The appropriate wizard file must exist. 

• The saved drawing properties listed in the wizard file must 
exist. 

• The saved select filters listed in the wizard file must exist. 

Model members which will be selected by the select filter 
must exist. 

 

Create Single-Part Drawings of Selected Parts 
We will now use a drawing wizard to create single-part drawings of selected steel 
beams and plates. 
1. Open the BasicModelCombined. Create single-part 

drawings of steel 
beams 2. Select the BEAM_STEEL from the drop down list of available Select filters. 

 

3. Select the whole model with an area selection. 

4. To view the creation of the drawings, open the drawing list by clicking the Open 
drawing list icon. 
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5. Select File > Wizard… from the menu or click the Wizard icon on the Standard toolbar 
to open the Wizard dialog box. 

 

6. Select Single Drawings on the Wizards tab. 

 

7. Click the Create from selected button. 

8. In the drawing list check that the single-part drawings with the title BEAM were created. 

 

9. Open a few single-part drawings for viewing. 
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Following the procedure above, now create the single part drawings of the plates. Create single-part 
drawings from 
plates 1. Select the PLATE select filter. 

2. Select the whole model with an area selection. 

3. Select Single Drawings on the Wizards tab in the wizard dialog box. 

4. Click the Create from selected button. 

5. In the drawings list check that the single-part drawings with the title PLATE were 
created. 

6. Open a few single-part drawings for viewing. 

 

Using the procedure outlined above, you could create single-part drawings from any 
other selected steel parts in the model (columns, braces, angles, etc.). 
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It is advisable to create all the single and assembly drawings 
with the wizard, even for a single part. 

Tekla Structures displayes a Cancel dialog box during the 
creation drawings. Click OK in the dialog box to stop creating 
the drawings. 

 

To create single-part drawings from all of the steel parts at once you can use the 
option Create from all. 

Create Assembly Drawings of All Parts 
Next we will create assembly drawings of all of the parts by using another drawing 
wizard. 

To create all of the assembly drawings: 
1. Click the Wizard icon to open the Wizard dialog box. Create assembly 

drawings 

 

2. Select Assembly Drawings on the Wizards tab. 

3. Click the Create from all button. 

 

 

Use the Create from all button to create drawings from the 
whole model at once. Note that Tekla Structures will not 
create single-part drawings or assembly drawings from 
concrete parts. 

 
4. In the drawings list check that the assembly drawings were created correctly (sort the 

drawing list by Title). 
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5. Open a few assembly drawings (which are not named STANDARD) for viewing. 

 

 

For parts that don't match with the drawing properties or 
filters listed in the wizard file, the predefine wizards creates 
drawings using STANDARD properties. 

 
1. Select drawings with the title STANDARD in the drawing list. Select parts with 

drawing title 
STANDARD 2. Click the Filter - Select parts button. 
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The parts associated with the selected drawing are now highlighted in the model. 
You will find that e.g. that objects like braces are highlighted in the model (the 
default wizard does not have a request for bracing). 
1. Select one vertical brace on gridline A. Open brace 

drawing 
2. Click the Display - All button to ensure that all drawings are shown in the list. 

3. Click the Filter - By parts button. 

 

The drawing list shows now only the assembly drawing created from the brace 
selected in the model. 
4. Open the drawing 

 

The brace drawing was created with standard properties and not properties defined 
for bracing. 

 

A drawing wizard will not create a duplicate drawing for any 
member already having, e.g. a single-part or assembly 
drawing. 
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11.3 Edit Drawing Properties 
We will now define specific drawing properties for both horizontal and vertical 
bracing and save the properties to be used later in the drawing wizard. 

As an example we will open one vertical brace drawing for editing. Using this 
drawing we will save the properties for the horizontal bracing. We will then edit 
some more properties and save them for the vertical bracing. 

We will edit dimensioning protection and part mark properties. To illustrate the 
effect of single fields, we will first remove the existing dimensions from the 
drawing. 

The editing we will do are just examples of using the drawing properties. The final 
drawing you get depends on the environment you are using and may not be identical 
to this example. 

Study the Online help for information on each of the separate fields available in the 
drawing properties. 
Help: Drawing > Dimensioning 

Help: Drawing > Drawing Properties 

 

Whenever possible, you should modify drawings by changing 
the drawing properties. These modifications remain when the 
drawing is recreated due to a model change. You can also use 
saved drawing properties in wizards. 

 
1. Right-click on the drawing and select Properties… to open the Assembly drawing 

properties. 
Load properties 
no_dimension 

2. Load the predefined properties no_dimensions. 

3. Click Modify. 

 

The drawing now appears without any dimensions and only the main view is visible. 

 Copyright © 2004 Tekla Corporation TEKLA STRUCTURES BASIC TRAINING  11 
  Assembly and Single Part Drawings  
 



By default, Tekla Structures creates the additional views only if it is necessary in 
order to show the dimensions in the drawing. 

However, for our purposes, we want to have both the front and top views in the 
brace drawings regardless of the dimensions that may be needed. 
1. In the Assembly drawing properties dialog box click the View… button Display both front 

and top views 
2. Choose the option on for the Front and Top views  

3. Click Apply and then Modify 

 

Now both the front and top views are displayed. 

 

The first dimension we will add is the main part overall dimension. 
1. In the Assembly drawing properties dialog box click Dimensioning… > Part 

dimensions. 
Main part overall 
dimension 

2. Select Once for Main part overall dimensions. 

3. Click Apply and then Modify. 
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The main part overall dimension appears. 

We will next add the dimension between the extreme bolts. 
1. On the Bolt dimensions tab select Assembly for Extreme bolts. Extreme bolts 

2. Click Apply and Modify. 
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The distance between the extreme bolts appears. 

We then continue by dimensioning the main part cuts 

To dimension the cuts in the main part: Main part shape 

1. On the Part dimensions tab turn Main part shape: to On. 

2. Click Apply and then Modify. 

Help: Drawing > Dimensioning > Dimension planes 

14 TEKLA STRUCTURES BASIC TRAINING  Copyright © 2004 Tekla Corporation  
 Assembly and Single Part Drawings   
 



 

 

The dimensions of the cuts appear in absolute dimensions. This is due to the 
dimension type defined in the Assembly – Dimension properties tab. We will change 
the dimension type to relative. 
1. In the Assembly drawing properties dialog box click Dimension… Change 

dimension type 
from absolute to 
relative 

2. Change the Dimension types / In X direction to relative (see fig below). 

3. Click Apply and then Modify. 
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The dimensions of main part cuts now appear as relative dimensions. 

 

By commenting environment variable, 
XS_NO_RELATIVE_SHAPE_DIMENSIONS, out the shape 
dimensions would always be relative despite the option 
chosen in the Dimension properties dialog box. 
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You can protect areas in drawings to prevent text or dimensions being placed there. 
This way you can e.g. prevent the part mark (1012 in the fig. above) overlapping 
with the dimension line. 

Protection 

 

In cases where Tekla Structures can not find a free place for 
an object the objects will overlap with each others despite the 
switches in the protection dialog box. 

 
1. In the Assembly drawing properties dialog box click Protection. 

2. Select the checkboxes shown below. These options define that Part marks may not 
overlap dimension lines. 

 

3. Select the checkboxes shown below. These options define that dimension lines may not 
overlap parts. 
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4. Click Apply and then Modify 

 

We will now save the properties that we have applied so far for horizontal bracing. 
We will then continue to edit the drawing little and save the properties for vertical 
bracing. 

For vertical bracing we want to see the secondary part bolt internal dimensions and 
change the part mark frame little. 
1. Type bracing_H in the Name: field of Assembly drawing properties dialog box. Save as 

properties for 
bracing_H 2. Type bracing_H_TR in the Save as field, click the Save as button 
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We will now add bolt dimensions to the vertical bracing. 
1. On the Assembly - Dimensioning properties > Bolt dimensions tab select Internal for 

Secondary part bolt internal dimensions. 
Secondary part 
bolt internal 

2. Click Apply and then Modify. 
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The bolt distance dimensions of the gusset plates appear. 

 

We will next change the part mark frame to be rectangular. Change the frame 
of part marks 

On the Assembly - part mark properties / General tab: 
1. Change the Frame around mark to rectangular. 
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2. Click Apply and then Modify 

The frames of part mark change to rectangular. 

 
1. Type bracing_V in the Name: field of Assembly drawing properties dialog box. Save as 

properties for 
bracing_V 2. Type bracing_V_TR in the Save as field, click the Save as button 

 

11.4 Create New Drawing Wizard 
We will next create a new drawing wizard that matches the select filters created 
earlier and the available drawing properties. We will add two new drawing requests 
to create horizontal and vertical braces and use the new properties defined for them. 
We will also save the properties for those parts that don't match our wizard to be 
shown as INCOMPLETE in the drawing list. 
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1. Load standard drawing properties. Create properties 
INCOMPLETE 

2. Edit the Name: field to INCOMPLETE. 

3. Save as the properties with name INCOMPLETE. 

 

We will now use an existing wizard as the basis for constructing our own wizard. 

To create a new drawing wizard, we will perform the following steps: 
1. Open an existing wizard file. 

2. Save it with another name. 

3. Modify the new file. 

4. Test the functionality of the new wizard. 

The following links present more information on customizing the wizard settings 
and the contents of a wizard file. 
Help: System > Files and folders > Customizing Tekla Structures > Creating wizard 
files  

Help: System > Files and folders > Log files > Wizard log 

To create the new wizard file: 
1. Click the Wizard icon to open the Wizard dialog box. Open existing 

wizard file 

 

2. Select Assembly Drawings on the Wizards tab. 

3. Click Edit to open the wizard file in a text editor. 
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1. Select Save as… from the File menu of the text editor to save the wizard file with 
another name. 

Save wizard file 
with another 
name 

2. Browse to the attributes folder under your model folder, enter ASSEMBLY_TR.dproc as 
the file name and click Save. Note that the file extension has to be .dproc. 

3. Check that the ASSEMBLY_TR.dproc file was created in the attributes subfolder by 
selecting Open model folder from the Tools menu. 

 

The predefined wizard files are located in the 
..\countries\*environment*\system folder. In the system folder 
the wizard files are available for use in all models. Modified 
and saved wizard files are saved in the same folder, unless 
you define another destination folder (such as the model 
folder). 

 

 

To have the new wizard file shown in the Wizard dialog box, 
you need to close and reopen the model. 
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1. Open the Wizard dialog box. Modify wizard file 

2. Select ASSEMBLY_TR on the Wizards tab and click Edit. 

3. Select an existing drawing request for purlins (shown highlighted below) and copy it 
two times under the original request. 
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4. Edit the requests that you copied, to match the criteria for vertical and horizontal bracing 
shown highlighted in yellow below. 
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5. Delete the requests that don't match our select filters: Delete requests 

• trusses 

• ladders 
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Next we will change all the requests to use the select filters that we defined earlier, 
for this project. 
6. Change the select filters defined for steel parts in this project: Change the select 

filters 
• column_filter to COLUMN_STEEL 

• beam_filter to BEAM_STEEL 

• purlin_filter to PURLIN 

• etc. 

 

7. Edit the last request to be as shown: Request for the 
rest of the 
assembly 
drawings 

/* Create rest of assembly drawings */ 
 
set_drawing_type(assembly) 
set_drawing_attributes(INCOMPLETE) 
set_filter(standard) 
create_drawings() 
 
8. Click Save to save the changes and to close the text editor. Save the wizard 

file 

 

A wizard file is comprised of several sets of drawing 
requests. The order of these requests is important, since Tekla 
Structures creates only one drawing for each selected object. 
The first request that matches the criteria of select filters is 
applied. 

 

Now we want to ensure that the new wizard file functions correctly. 
1. Delete all of the assembly drawings in the drawing list. Apply own wizard 

file 
2. Open the Wizard dialog box, select the ASSEMBLY_TR wizard and click Create from 

all. 
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3. Check the drawing list to see that correct drawing properties were used: 

• The titles of the created assembly drawings 

• INCOMPLETE 

• bracing_V, bracing_H 

11.5 Create Drawings Manually 
In Tekla Structures, you can create single-part and assembly drawings by loading 
and applying predefined drawing properties for layout, dimensions, marks, etc. for 
selected parts. This process is called the manual creation of drawings, in contrast to 
the drawing creation with wizards. 

The steps for the manual creation of drawings are basically the same as the steps 
used by the drawing wizard: 
1. Select the model objects. 

2. Load the predefined drawing properties. 

3. Click Drawing > Assembly drawing to create assembly drawings or Drawing > Single-
part drawing to create single-part drawings. 

Create Assembly Drawings 
As example, we will create assembly drawings from the columns. 

To manually create assembly drawings from all columns: 

Open the drawing list and delete all assembly drawings with the title COLUMN. Delete column 
assembly 
drawings Create assembly 
drawings from 
columns 

1. Select the column_filter on the Select switches toolbar and select the whole model. 

2. Select Properties > Assembly drawing… in the menu to open the Assembly drawing 
properties dialog box. 

3. Select column properties in the drop-down box next to the Load button. 
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4. Click Load and OK. 

5. Select Drawing > Assembly drawing in the menu to create the assembly drawings. 

6. Open the drawing list and check that the correct drawings were created. 

 

You can also use the view filters in the View filter dialog box 
(opened from the View properties dialog box) to help 
selecting members in the model for drawing creation. 

 

11.6 Edit Drawings Manually 
It is possible to manually add and edit additional drawing objects (i.e. dimensions, 
lines, text, symbols, graphics and marks) in Tekla Structures drawings. 

 

Whenever possible, you should modify drawings by editing 
only the drawing properties. For example, if you use the 
drawing properties to modify the drawing, the modifications 
remain if the drawing must be recreated due to a model 
change. 

 

We will now edit a brace_H drawing manually to include same editing that we 
defined for vertical brace_V drawing properties (the bolt distance dimensions and 
the rectangular part mark frame). 
1. Open the first bracing_H drawing in the drawing list. Add bolt distance 

dimensions 
2. Click Create Y dimension icon. 
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3. Pick the center points of bolts to be dimensioned. 

4. Move the cursor to where you want the dimension to appear and click the middle button. 

 

 

To move the dimension: Select it and drag it to the desired 
position. 

 

Add the bolt dimension to the other end the same way. 
1. Double-click one of the part marks to open Part mark properties dialog box. Change the frame 

of part marks 
2. On General tab change the Frame around mark to rectangular and tick only this check 

box. 
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3. Select all the part marks in the drawing. 

4. Modify. 

 

Now all the part marks in the drawing have rectangular frames. 

5. Close the drawing, click Save in the confirmation dialog box. 
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1. Open the second bracing_H drawing. Edit the other 
bracing_H 
drawing 2. Add the bolt distance dimensions. 

3. Change the frame of part marks to rectangular. 

4. Close the drawing, click Save and Freeze in the confirmation dialog box 

 

An F appears in the drawing list to show this drawing is frozen. 

Now the drawings of the horizontal bracing have the same editing as the vertical 
bracing. The difference is that part of the horizontal brace editing was done 
manually. 

11.7 Updating Assembly and Single-part Drawings 
We will now modify our model by changing the bolt spacing of all of the gusset 
plate connections. Changes in the model will result in some of the drawings will no 
longer be up-to-date. To be able to open the drawings you will need to run 
numbering and update them. 

We will study how updating effects the edited drawings. 

Updating will: 

• Regenerate any drawings with a P flag that are unfrozen, the updating deletes all the 
manual editing (added dimensions, texts etc.). 

• Update the quantities on a drawing with an N flag. 

• Switch the P flag on a frozen drawing to an *. This indicates that the picture (the parts 
and bolts) and the marks of the member have been updated but not the dimensions. 

Changes in the Model 
1. Select all the connections in the model. Change gusset 

plate bolt spacing 
2. From the page 4 connection toolbar, double-click the Tube gusset (20) icon. 

3. Check that the Ignore other types is selected in the connection dialog box. 

4. In the Tubebolts1, Tubebolts2 and Tubebolts3 tab pages edit the vertical bolt spacing 
to 80 as shown below. 
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5. Click Modify. 

Now the model has changed and some of the drawings are no longer up to date. To 
be able to open the drawings you need to run numbering and update them. 

Select Tools > Numbering > Modified. Run numbering 

Once the numbering is carried out the flags in the Drawings list shows all of the 
affected drawings that need to be updated. 
Help: Drawing > Getting started with drawings > Drawing status flags 

 

The vertical brace drawings were created with only the predefined drawing 
attributes. They will be complete right after updating, since they are simply 
recreated using their own attributes. 

Update vertical 
brace drawings 

To update drawings: 
1. Select the bracing_V drawings from the list. 

2. Click Update. 

3. Open the drawings to see that they are ok. 
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Since the drawing is not frozen the updating regenerates the drawing but deletes all 
the manual editing (in this case the added bolt dimensions and part mark frame 
change). 

Update not frozen 
horizontal brace 
drawing 

 

There is no Undo for the updating the drawings command. 

 
1. Select the bracing_H drawing that is not frozen. 

2. Click Update. 

3. Open the drawing 

 

You can see the manually added dimension has disappeared and the part mark frame 
is back to rounded. 
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Updating a frozen drawing updates the picture of the member and the marks, but not 
the dimensions or manual editing. We will need to fix up any dimensions that need 
updating. 

 

The fact that a lot of time can be spent editing drawings, it is 
advisable to always freeze manually edited drawings. If 
major modifications in the model create problems with a 
drawing you can always recreate the drawing with the 
automatic settings. 

 

To update frozen drawings: Update frozen 
horizontal braze 
drawing 1. Select the frozen bracing_H drawing from the list. 

2. Click Update. 

3. The P gets replaced by an *. 

 

4. Open drawing with an *. 

 

You can see that the bolt dimension still appears but is not correct. 

 

Updating a frozen drawing can lead to a situation of 
incomplete or erroneous dimensioning. You must manually 
complete or edit the dimensioning. 

 
5. Select the dimension line and click the Add / remove dimension point icon. 

 

6. Pick the correct points (the center points of bolts) to dimension. 

7. Click Add / remove dimension point icon. 

8. Use Shift and pick the wrong dimension points to remove them. 

The dimension is now correct. 
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9. Save the drawing and the * flag will be removed. 

 

You can filter up-to-date drawings with Filter > Up to date 
button. To get non up to date drawings listed press Display > 
Invert button after Filter > Up to date. 

It is not possible to open earlier revisions of the drawings. 
Due to the integration between drawings and the model a 
drawing that is not up-to-date cannot be opened. 

11.8 Cloning Drawings 
For more information, see Help: Drawing > Getting started with drawings > Working 
with drawings > Cloning drawings. 
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