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In this lesson

Introduction

Catalog

This lesson explains how to view and modify the catalogs. Y ou will learn how to create a
new profile cross section and how to define arule group for it. You will aso learn how to
add a parametric profile to the profile catalog and how to add user-defined information in
existing catalogs. After the profile catalog has been updated, the new profile will then be
used for modeling.

In thislesson you will also learn how to add a new material type and anew grade to the
material catalog.

Catal ogs are databases containing detailed information about profiles, materials and bolts,
which are available for use in your project. For example, the bolt catalog contains a library of
standard bolts and bolt assemblies used in structural steelwork. Catalogs can also contain
project or company-specific information. Catalogs can also be imported and exported.

See morein Tekla Structures Help: System > Catalogs > Things you should know about
catalogs.

See more for profile import and export in Tekla Structures Help: System > Catalogs > The
profile catalog > Merging profile catalogs.

See more about material catalogsin Tekla StructuresHelp: System > Catalogs> The
material catalog.

6.1 Modify Profile Catalog — Add a New Profile

In this exercise we will define a new cross section and profile using Tekla Structures Profile
cross section from plate (S10) macro, which provides you with the ability to create user
defined cross sections and user-defined profiles automatically from a contour plate. The
macro adds the profile and the cross section to profile catalog. We will first create a contour
plate to define the shape of the new cross section, and then we will use the new profile in our
model.

Define the Cross Section Shape

Create a contour
plate

Y ou can create the contour plate in any Plane angle view. See more about viewsin Tekla
Structures Help: Modeling > Getting started > Views > View properties.

First we will create a polygon by picking corner points according to the dimensions shown
below. For now, we will just pick the points which describe the outline of the profile, later
we will modify those corners which need to have aradius.

Copyright © 2004 Tekla Corporation TEKLA STRUCTURES BASIC TRAINING 3

Catalog



Before starting to create the polygon, check that you have Snap to any
position on, in Snap settings toolbar. Also set ortho to on by pressing the
letter O

1. Pick theCreate contour plate icon.

-

2. Pick any starting point for the polygon.

Move the cursor in the desired direction for a second point.

On the keyboard, enter a distance. Tekla Structures will automatically open the Enter a
numeric location dialog.

5. PressEnter. Tekla Structures creates a new point at the given location.
Repeat for each corner point for the whole polygon outline.

Close the polygon by clicking the middle button.
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Add rounding to We will next complete the cross section shape by modifying the contour plate inner corners,
the contour plate  which require aradius. First zoom in to one of the contour plate corners, which need a

1. Pick the contour plate chamfer. See more about chamfersin Tekla Structures Help:
M odeling > Detailing > Detailing commands > Chamfer.

2. Double-click the chamfer to open the dialog and then select the round chamfer type from
pull-down list.

3. Enter avaluefor the radius and press Modify. Tekla Structures rounds the selected
chamfer.

4. Leavethe dialog open and select the other chamfers, which need to be rounded and
press Modify.

' _ Thecontour plate can have rounded chamfers, holes, part adds or cuts. They
are transferred to the cross section and further to the profile using Tekla
Structures Profile cross section from plate (S10) macro.

Create the Profile

Add a new profile When the contour plate shape has been completed, you are ready to add your own cross
to catalog section and profile to profile catalog using Tekla Structures Profile cross section from
plate (S10) macro.

It isimportant that your work planeis parallel to the plate. E.g. if you create
the plate in the x-y plane (i.e. on the ground) then ensure that your work plane
isin the same plane (i.e. in the 3d view).

See more about work plane in Tekla Structures Help: Modeling > Getting
started > View reference >View > Workplane > Work plane...

1. Open Profile cross-section from plate (10) dialog box by double-clicking the icon on
connections toolbar.
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Define profile On the Parameters tab page we will enter a name for the profile cross section and the profile
parameters (blank spaces are NOT dlowed in name). We must aso decide where the new profile will be
saved.

2. Enter Section name (be sure that the nameis not aready in use; Tekla Structures will
overwrite the existing name).

3. Enter Profile name (note that section and profile can have same name).

4. Select the directory, where the profile catalog will be saved. See more about foldersin
Tekla Structures System > Files and folders> Folders.

5. Enter the profiles weight / ms.

Define profile Next we will define the profile's type and main dimensions. See more in Tekla Structures
attributes System > Catalogs > The profile catalog.

6. Select the Profile attributes tab page.
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7. Select the profile type from the pull-down list.
8. Enter the profile's main dimensions.

Create profile After you have entered all of the necessary information in the dialog, you can add the profile
to the profile catalog.

9. Press Apply. Tekla Structures prompts you to pick the object, pick the contour plate.

After you have picked the plate, Tekla Structures generates a new profile cross section and
adds the profile to the profile catalog. Tekla Structures also creates a sample profile on top of
the contour plate.
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Check the Results

Once the profile has been created, the next step isto see that the result is correct. We will
first open the profile properties dialog and check its content. Then we'll check the profile

catalog.
Check profile 1. Double-click the new profile. Tekla Structures opens aBeam properties dialog.
properties
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2. Check that Profile field has the correct profile name.
3. Closethe Beam properties dialog.

Check profile 1. Select Catalog > Profiles > Modify... from the File pull-down menu to access the Tekla
catalog Structures Profile catalog. See more information about profile catalog in Tekla
Structures Help: System > Catalogs > The profile catalog.
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2. Findthe new profile under User defined, fixed rule group. Tekla Structures places user
defined profiles automatically under thisrule.

3. Check the profile dimensions and general information on the General tab page. See that
the cross section name in the Profile subtype field is the same as you defined in the
macro dialog. Also check that the Equivalent type, which was defined in the Type field
in the macro dialog, is correct.

4. Pick the Analysis tab page. Tekla Structures has automatically calculated the cross
section area and unit weight for the new profile. Check that they are correct.

5. Pressthe OK button to save the profile and close the dialog.

Use the Profile in Model

Define beam Once the profile has been created we can immediately use it in our model. Compl ete the
settings settings in beam properties dialog and start creating the crane beams.
10 TEKLA STRUCTURES BASIC TRAINING Copyright © 2004 Tekla Corporation

Catalog



1. Double-click the Create beam icon and complete the beam properties as described
below.

2. Select MY_I_PROFILE from Select profile list dialog under Library profile category >
User defined, fixed rule set.

3. PressOK on both dialogs.

Create the cranes When the beam settings are ready we can begin to create the crane beams. First we will
create one beam and check that the shape and position are correct.

1. Zoominto intersection of grid lines F and 1 on top of the IPE450 supporting beam.

2. Create one crane beam between lines 1 and 4. Start at the outer edge of the supporting
beam on line 1, end at the middle of the supporting beam on line 4.

Select the crane beam and copy it between the grid lines4 and 7.
Select both crane beams and copy them to the other side of the building on grid line C.
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We now have crane beams on both sides of the building.

Add a Rule to Profile Catalog

Next we will add arule for the new profile in the profile catalog. Profiles are grouped
according to rules such as profile type (e.g. | profiles) and profile sub-type (e.g. HEA). See
more about rulesin Tekla Structures Help: System > Catalogs > The profile catalog >
Working with rules.

Add arule 1. Right-click on the profile tree dialog (File -> Catalog -> Profiles -> Modify...), click
Add rule to display the Profile manager rules dialog box.

Typein the Rule name My properties.
Choose the Profile type to which the rule will be applied.

Enter the Name filter string that will define the new rule. Tekla Structures groups the
catalog entries that satisfy your criteria under anew rule. In this case, to group all
MY_PROFILES enter *MY* in the name filter field. See more about filtersin Tekla
Structures System > Catalogs > Things you should know > Thefilter.
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5.

As adefault the wildcard symbol (*) is entered, meaning "all entries’. To
group al catalog entries with names beginning with A, enter A* asthe Name
filter string. To group all catalog entries with names containing 100, enter
*100*. The characters* and ? can also be used in object names. If the object
name you want to filter contains* or ?, enclose * or ?in square brackets. E.g.,
to find the profile P100* 10, enter P100[*]10 in the filter field.

Press OK to save the rule and close the dialog.

Add User-Defined Information to Profile

We will next add the profile manufacturer information into the profile catalog by way of
user-defined attributes. For that you need to re-open the profile catalog. See more in Tekla
Structures System > Catalogs > The profile catalog > Adding user defined attributesto a
profile.

Create anew user  Select the User attributes tab pagein the Modify profile catalog dialog.

attribute

1.

o~ 0N

Enter value for the
attribute

=

Pressthe Definitions... button. Tekla Structures opens a Modify profile properties
dialog box.

Press Add. Tekla Structures creates a new user defined attribute.
Select User defined, fixed profile type from pull-down list.
Check that Quantity type is set to String.

Under Property name enter a unique name (e.g. MANUFACTURER) for the new
attribute. Blank spaces are NOT allowed in the name.

Enter aname (e.g. Manufacturer) for the attribute under Label. Thistext will be
displayed in the dialog.

Press Update. Tekla Structures updates the attribute val ues.

Press OK to save the information. When re-opening the Modify profile properties
dialog, the new attribute appears under User defined, fixed -type profiles.

Select MY_I_PROFILE from profile catal og.

Insert a manufacturer name (e.g. My workshop) into Value field on the User attributes
tab.
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3. PressUpdate to enter the information to selected profile.

4. PressOK to save the information and close the dialog.

Add a Library Profile — Parametric Profiles

We will next add a standard (fixed) profile to the profile catalog using a pre-defined
parametric profile. This makes it faster and easier to select the necessary profile when adding
it to the model; otherwise we would have to define the dimensions for the parametric profile
in the beam properties dialog.

See more information about profile catalog in Tekla Structures System > Catalogs > The
profile catalog.

Add profile
1. Select Catalog > Profiles > Modify... from the File pull-down menu.

2. Right- in the tree structure and click Add profile. A new profile will be created with the
name PROFILE (number).

Set profile 3. Changethe profile name to MY_FOOTING_BEAM1. The profile name must be
properties uppercase, with no spaces. Tekla Structures will automatically convert lowercase text to
uppercase in thisfield.
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4. Choosethe Profile type, User defined, parametric from pull-down list and the Profile
subtype StdLib.SK.

5. Enter dimensions for the profile. These dimensions will be fixed on the part properties
dialogs, and can be changed only in the Modify profile catalog dialog.

Press Update to insert the values to the profile.

Press OK to save the values.

6.2 Use the New Library Profile — Add Footing
Beams to Model

We will next use the new library profile to model footing beams.

Define Beam Properties

We will first set the beam properties, find the correct profile and set the correct position.

Select the profile 1. Double-click Create concrete beam icon to open the properties dialog.
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2. Select the new profile by pushing ... (Browse) button. Tekla Structures opens the Select
profile dialog.

Select Library profile for profile category.

Select MY_FOOTING_BEAML1. The dimensions are fixed and can only be changed in
the Modify profile catalog dialog.

5. Press OK to accept the profile and to close the dialog. MY_FOOTING_BEAM1 appearsin
Shape field in the Concrete beam properties dialog.

Set the position 6. Select the Position tab page and set the position as shown below.
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7. PressOK in Concrete beam properties dialog to accept the beam settings and to close
the dialog.

Create Footing Beams

When the beam settings have been completed you can start creating the footing beams.
Create first one beam and check that the shape and position are correct.

Create footing 1. Pick the starting point for footing beam on plane view +0.00 at the outer corner of
beams column.

2. Pick the end point for the footing beam on plane view +0.00 at the intersection of the
grid line and the column outer plane.
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Complete by clicking the middle button.

Check the position by creating part views. Pick the footing beam, right-click and select,
Create view > Part basic views...

5. Select the Create concrete beam icon again and create the next footing beam. Make the
start point at the end point of previous beam and the end point at the next grid line.
Repeat for the next beam. Y ou should now have 3 footing beams at grid line 7.

6. Skip the corner and continue creating footing beams between grid lines 6 and 4.

Create Polybeam

We will now create a footing beam to wrap around the corner using the polybeam function.

See more about polybeamsin Tekla Structures Help: M odeling> Parts > Steel part
commands > Polybeam.
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_ Third point
First point A . |
Second point
Create footing 1. Select Create concrete beam icon again and pick the starting point at the end point of
polybeam beam between grid lines E and F.

Then pick to the column outer corner.
Make the third pick at grid line 6.
4. Complete the polybeam by clicking the middle button.

Complete Footing Beams

Create the 1. Continue by creating the footing beams on grid line 3.
remaining footing .
beams 2. Create another footing polybeam at the corner.

3. Createthe last two footing beams between grid lines E and C.
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6.3 Modify Material Catalog — Add a New Material

We will next add a new material called Neoprene to the catalog. Neoprene will be used later
on concrete consoles.

See more about material catalog in Tekla Structures System > Catalogs > The material
catalog.

Add a New Material Type

We will first create a new materia type under which the new materia will be created.

Open the material Select File > Catalog > Materials > Modify... from File pull-down menu to open the Modify
catalog material catalog dialog.

Create a new If the material type you need is missing from the tree, you can creste a new one.

material type . . . . ]
1. Right-click on amaterial branch in the tree and select Add miscellaneous branch.
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Add a New Material

We will next add a zero-weight material under the miscellaneous branch and useiit for silos
in the model.

Create a new 2. Right-click on Miscellaneous branch in the tree and select Add grade.
material grade

3. TypeZero_weight for the material namein thetree.
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Change material

of the silos button down to open the properties dialog.

1. Select Zero_weight material from Select material list.

2. Close Select material dialog by clicking OK.

3. Push Modify button in the Column properties dialog to change the material of the silos.
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4. Addthe materia's density 0.00 for profiles and plates.
5. Savethe new material type and grade by pressing OK.

We will next use the new zero-weight material for the silosin order to exclude the silos out
from the total weight of the model.

Select the two silos in the model and double-click on one of them while holding the Shift
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