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1 Basic Modeling 2 

In this lesson 

In this lesson we will cover some preliminary tasks that you need to do before starting to 
model in a real project. We will create a new model and recap the basic functions introduced 
in Lesson 1. After that, you will learn some more about the basic functions. 

You will learn how to: 

• Set up project- information 

• Define part properties and numbering series 

• Work in true planes (sloped, skewed) 

• Use phases 

• Combine separate models 

• Create your own select filters 
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1.1 Start a New Model - BasicModel2 
Start a new model and name it BasicModel2. 

Create New Model 
1. Pick the New icon. Start a new model 

 

2. Click after the path C:\TeklaStructuresModels, in the field at the bottom of the dialog 
box and type \BasicModel2. 

3. Press the OK button and the model will be created. 

Create Grid 

 

To create the appropriate grid for BasicModel2 modify the existing default grid. 

1. Double-click the grid line. Modify the 
existing grid 

2. Edit the grid, in the Grid properties dialog box, according the grids shown above 
(coordinates and text). 

3. Edit the grid origin Y0 value to 13900. 
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4. Click Modify, and the new grid values will be applied. 

5. Enter GRID2 in the save as field and click the Save as button to save the grid values. 

1. Left-click anywhere in the view. Fit work area 

2. Right-click and select Fit work area. 

The view should now look like the one below. 
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Create Plane Views along Grid Lines 
We will now create Elevation and Plan views along the grid lines. 

1. Select the grid. Create grid views 

2. Right-click and select Create view > Grid views from the pop-up menu. 

3. Click the Show… button on each view plane to open the View properties dialog box, 
set the view properties the way you want and click OK. 

4. Click Create in the Creation of views along grid lines dialog box. 

1.2 Setting Up Job Specific Information 
Prior to adding any parts we will setup the model with the necessary job specific 
information: 

• Project properties 

• Preferences 

• Part properties and numbering series 

Project Properties 
Project properties are common to all drawings and can be used to fill in typical information 
in the title blocks. 

1. Open the Project properties dialog box by selecting Properties-> Project… Set up project 
properties 

2. Fill in the information as shown in the dialog box below. 

3. Press OK. 
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Check Preferences 
Before starting the modeling we will check that preferences are set up correctly. 

Help: System > Using Xsteel effectively > General > Preferences 

 

Check that your preferences are set up correctly before you start modeling. If 
you change settings on the Preferences tab, Tekla Structures only applies the 
new settings to connections you subsequently create. Connections you created 
prior to changing the preferences are not affected. 

 
1. Open Setup > Options… Check 

preferences 
2. On the Preferences tab check the values are as below, click OK. 

 

Part Properties and Numbering Series 
You use a numbering series (numbering prefixes and start numbers) to divide parts, 
assemblies (steel detailing) and cast units (concrete detailing) into groups. For example, you 
can allocate separate numbering series to different phases or part types. 

 Copyright © 2004 Tekla Corporation TEKLA STRUCTURES BASIC TRAINING  7 
  Basic Modeling 2  
 



You can name the numbering series to which a part, assembly or cast unit belongs, by using 
the part properties dialog box. The numbering series name consists of a prefix and a starting 
number. 

If you already know in the beginning of the project how the members should be numbered it 
is a good idea to create the parts right from the start with the correct numbering series. 

Help: Modeling > Parts > Numbering parts > Defining numbers to be used for parts 

In Lesson 9 Numbering and reports, you will learn the basics of numbering parts in Tekla 
Structures; how numbering series result in different part / assembly /cast unit numbers, 
numbering settings etc. 
Go through each of the part properties dialog box (Beam properties, Column properties, 
Contour plate properties, etc.) and set them up with the information shown in the tables 
below and save each of them with a specific name. See the Adjust Beam properties example 
below the tables. 

Set the part 
properties 

Steel Members 
Parts/ 
command 

Part 
prefix 

Part 
start no. 

Assembly 
prefix 

Assembly 
start no. 

Part name Material Class 

Beam 
command 

       

Beams PB 1 AB 1 BEAM S355JR 6 

Vertical 
braces 

PV 1 AV 1 BRACING_V S355JR 3 

Horizontal 
braces 

PH 1 AH 1 BRACING_H S355JR 3 

Rafters PR 1 AR 1 RAFTER S355JR 9 

Purlins PP 1 AP 1 PURLIN S355JR 8 

Column 
command 

       

Columns PC 1 AC 1 COLUMN S355JR 7 

Silos PX 1 AX 1 SILO S355JR 1 

Contour 
plate 
command 

       

Plates  1001 A 1 PLATE S355JR 99 
 

Concrete Members 
Parts/ 
command 

Cast unit 
prefix 

Cast unit 
start no. 

Part name Material Class 

Concrete 
beam 
command 

     

Beams CB 1 BEAM K40-1 4 

Hollowcore 
slabs 

CH 1 HCSLAB K40-1 1 

Concrete 
column 
command 

     

Columns CC 1 COLUMN K40-1 3 
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Pad footing 
command 

     

Pad footings CP 1 FOOTING K40-1 2 

Concrete 
slab 
command 

     

Slabs CS 1 SLAB K40-1 4 
 
1. Open the Beam properties dialog. Example: Adjust 

beam properties 
2. Match the highlighted fields in the dialog box below. 

Type the part name BEAM in the save as field and click the Save as button. 

 

Save Defaults 
After you have setup the properties, you must save the Project properties and Preferences 
for this model with the Save defaults command. 

The Save defaults command creates a set of standard files which also include the part 
properties files. These standard properties are loaded when you open the model. 

In other words, when you want specific properties to be loaded by default when you open a 
model, setup and load the properties before using the Save defaults command. 

Help: System > Files and Folders > Customizing Xsteel > Save defaults 

Click Setup > Save defaults. Save Defaults 
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1.3 Create Concrete Members 
First we will create pad footings, columns, and beams on grid line 1 and then copy them all 
at once to the other grid lines. 

We will then create a slab on top of the columns/beams at level 7175. 

Pre Cast Footings 
We will now create foundations on grid line 1. 

 

1. Double-click the Create pad footing icon. 2700*2700 footing 

 

2. Load the saved FOOTING properties. 

3. Enter the Pad footing information in the dialog box for a 2700*2700 footing as shown 
in the drawing (set the profile to 2700*2700, Bottom level to –650 and Top level to 0). 

4. Click Apply. 

5. Pick grid intersections C-1 and F-1. 

While still in the command: 2100*2100 footing 

6. Enter the Pad footing information in the dialog box for a 2100*2100 footing (set the 
profile to 2700*2700, Bottom level to –650 and Top level to 0). 

7. Click Apply. 

8. Pick grid intersections D-1 and E-1. 

The footings should now look like those shown below: 
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Pre Cast Columns 
Now we will create the columns on grid line 1. 

 

1. Double-click on the Create Concrete column icon. 900*600 Columns 

 

2. Load the COLUMN properties that you saved earlier. 

3. According to the drawing shown above, enter the information in the Concrete column 
properties dialog box for a 900*600 column, and click Apply. 

4. Pick the intersections of grids C-1 and then F-1.While still in the command: 

Complete the dialog for 600*600 columns and create them on grid intersections D-1 and E-1. 600*600 Columns 
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Pre Cast Beams 
We will now create the beams on grid line 1 at level +7175. 

 

1. Double-click the Create concrete beam icon. Create beams 

 

2. Load the BEAM properties that you’ve saved. 

3. Enter the information in the Concrete beam properties dialog according the drawing 
above, click Apply. 

4. In the GRID 1 view pick the intersection of gridlines C-7175 and then D-7175. 

5. End the command by clicking the middle button. 
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6. While on grid line 1, create the other two beams the same way. 

 

Copy the Members 
We will now copy the footings, column and beams that we created to grid lines 2-7. 

1. Select the footings, columns and beams. Copy the 
members 

2. Right-click and select Copy > Translate… from the pop-up menu. 

3. Pick two points to show the translation vector (6000 in X direction). 

4. Type in the number of copies (6). 

5. Click Copy. 
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Insitu Slab 
We will now create a 350 mm slab on top of the framework by using the outermost corners 
of the columns. 

1. Double-click the Create concrete slab icon. Create the slab 

2. Load the SLAB properties that you saved earlier. 

3. Complete the Concrete slab properties dialogue box as shown and Apply this. 

 

4. In the PLAN +7175 view pick the outermost corners of the four columns as shown. 
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5. Click middle button to create the slab. 

 

1.4 Create Steel Members 
First, we will create two columns on grid line 1 and then a rafter between them. 

After that we will create the construction points needed to create the horizontal bracing and 
purlins. We will copy translate the completed portal frame and points. By taking advantage 
of sloping work plane and view planes we will model the horizontal bracing and purlins. 

Finally we will create vertical bracing on grid lines C and F. 

Steel Columns 
We first create two columns on grid line 1. 
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1. Double-click the Create column icon. Create columns 

 

2. Load the COLUMN properties. 

3. Complete the Column properties (profile and the levels) for the column at the grid 
intersection C-1 as shown in the figure above and click Apply. 

4. Pick the grid intersection C-1 to create the column. 

5. Complete the Column properties for the column at grid intersection F-1, and click 
Apply. 

6. Pick the grid intersection F-1 to create the second column. 

Since the profile depth of the concrete and steel columns are different (900*600 => h=900 
while HEA 800 => h=790) middle positioning results a gap in the outer face. 

 

Use the Measure tool to measure the distance from the edge of the column to the edge of the 
slab. 

16 TEKLA STRUCTURES BASIC TRAINING  Copyright © 2004 Tekla Corporation  
 Basic Modeling 2   
 



1. Click the Create x measure icon. Measure the gap 

 

2. In the grid 1 view pick the point in the slab corner then the point in the column corner. 

3. Pick a position to place the dimension. 

 

Adjust the column edge to the slab (and concrete column) by using the vertical position 
offset in the Column properties dialog. 

Adjust the vertical 
position 

1. Open Column properties dialog box. 

2. Modify the column on grid line F using a vertical offset of 55. 

3. Modify the column on grid line C using a vertical offset of -55. 
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Steel Rafter 
Now we will create a rafter between the 2 columns that we just created. 

 

1. Double-click the Create beam icon. Create rafter 

2. Load the RAFTER properties. 

3. Enter the rafter information in the dialog according the drawing above (Profile: 
IPE750*160) and click Apply. 

4. In the GRID 1 view pick the intersection of grids C-20200 and then F-18200. 

 

Work Points for Horizontal Bracing and Purlins 
After inputting the two columns and the rafter, we will layout points for modeling the 
purlins, vertical and horizontal braces. 
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Bracing Work Points 
We need first to create points at the intersection of grid C and rafter centerline and 
intersection of grid F and rafter centerline. Then using the points we will create work points 
for the braces. 

To create a point at the intersection (shown with red arrow) of grid C and rafter centerline: 

1. Double-click Create divided line points command. Intersection of 
grid and rafter 
centerline 

 

2. Type in 1 (1points) and pick the positions shown below. 

 

To create the point in the intersection of grid F and rafter centerline on the other end of the 
rafter we simply copy the first point. 

Copy the point to 
the other side 

1. Select the point just created, right-click and select Copy – Translate… 

2. Pick the start point of the rafter then the end point of the rafter, click Copy. 

 

We will now create the work points for first and last brace. 

1. Double-click Create extension point icon. First and last 
brace work points 
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2. Type in –800, click OK. 

3. Pick from one of the points just created then the other. 

 

4. Repeat, picking the points in the reverse order 

Using the Create divided line points command divide the space between the work points 
that you just created into ten equal spaces (9 points). 

1. Double-click the Create divided line points icon. Divide the 
working points in 
ten segments 

 

2. Enter 9 as the number of dividing points, click OK. 

 

3. Pick from one of the work points that you just created and then the other. 

Purlins Work Points 
We can now use the grid intersections C-20200 and F-18200 to create the work points for 
first and last purlins. 

1. Double-click Create extension point icon. First and last 
purlins work 
points 

 

2. Type in –600, click OK. 

3. Pick the grid intersections C-20200 and then F-18200. 

4. Repeat, picking the points in the reverse order. 
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Using the Create divided line points command divide the space between the work points 
that you just created into 12 equal spaces (11 points). 

Divide the 
working points in 
12 segments 

Copy the Portal Frame and the Points 
We will now copy the columns, rafter and the points to grid lines 2-7. 

1. Select the columns, rafter and points. Copy the 
members 

 

2. Copy > Translate… 

3. Pick two points to show the translation vector (6000 in X direction). 

4. Type in the number of copies (6). 

5. Click Copy. 

 

Set Sloping Work Plane for Bracing and Purlins 
The next step is to model the horizontal bracing and purlins at the sloped roof. To place the 
parts in the correct plane we will first change the work plane (which currently is the local 
coordinate system of the model) to the roof slope. 
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Help: Modeling > Getting Started > Basics > Defining the work area and shifting the 
work plane 

Help: Modeling > Getting Started > View reference > View > Work plane > To part 
plane 

To set the work plane to the roof slope: Set work plane to 
the roof slope 

1. Pick the Set Work plane to part top icon. 

 

2. Pick the rafter on grid line 1. 

The work plane is now positioned in a plane parallel to the top plane of rafter. 

 

 

The Set work plane to part plane command sets the work plane parallel to the 
part plane (front top, back, bottom) on the center line of the part. 

 

 

You can use the command, Work plane > With one point, to set the work 
plane exactly to the desired position. This command keeps the work plane 
parallel to the current work plane, but moves it to a new position using a single 
picked point. 

 

True Plan View 
To make it easier to add the roof bracing we will now make a true plan view on the roof 
bracing by creating a view perpendicular to the work plane. We can also use the true plan 
view in drawings. 

 

Working in a true plan view makes it easier to model E.g. sloped objects since 
the grids are also shown in the true plan and points in the view plane are 
represented as yellow crosses. 

The part positioning, copying etc however always comply with the work plane 
coordinate system no matter in which view you perform the commands. 
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1. Pick Properties > View... Create true plan 
view 

2. Complete the properties as shown below, click OK. 

 

3. Select View > Create view > To workplane. 

The new view is created. The work points created for braces appear in yellow since they are 
now on the view plane. The grid is also shown in the true plan view plane. 

 

Create Horizontal Bracing 
Working in the true plan view we will next create the horizontal bracing members using the 
Create beam tool. 

1. Double-click the Create beam icon. Create horizontal 
bracing 

2. Load the BRACING_H properties. 
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Complete the dialog box according to the information shown in the drawing above and 
change the Position at depth to: Middle and Apply. 

3. In the true plan view create the braces shown in the drawing by snapping to the yellow 
points. 

 

Check the position of the braces in the 3d view and elevation view on grid 1. Check the 
positioning 

 

We will now copy mirror the braces to the other end of the building (between gridlines 4 and 
5). Since the work plane is now at the same slope with the TRUE PLAN view, it is easy to 
pick the points for the mirror line. 

 

The Copy > Mirror command copies and mirrors objects through a plane that is 
perpendicular to the work plane and passes through a line you specify. 
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1. Select the braces. Mirror the braces 

2. Copy > Mirror. 

 

3. In the True plan view pick two points on gridline 4 to set the mirror line and click 
Copy. 

 

Create Purlins 
While still working in the true plan view we will create the purlins by using the Create beam 
tool. 

1. Double-click the Create beam icon. Create purlins 

2. Load the PURLIN properties. 

3. Select a Z300/3.0 profile for the purlin. 

4. Change the Position / At depth to: Front and Apply. 

 

5. Pick the purlin work point near grid intersection F-1 at the command Pick first 
position. 

The point that you pick for the purlin is red since it is not on the view plane. 

6. At the command: Pick second point, pick the work point near grid intersection F-2. 
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7. Check the elevation view on grid 1 to ensure that the purlin is orientated and positioned 
correctly. 

 

 

With asymmetric profiles (Z,L etc) the picking order of first and second 
position determines the orientation. It is not possible to change the orientation 
using the beam properties. 

 
8. Create the rest of the purlins by using the Copy > Translate command. 

Now we must switch the work plane back to global origin to carry on modeling outside of 
the roof plane. 

Set the work 
plane back to 
global origin 

1. Pick View > Work plane > Work plane… 

2. Select Plane: XY set the depth coordinate to 0 and click Change. 
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The work plane is now set back to the global origin. 

 

Vertical Bracing 
Working in the elevation on grid C view we will create vertical bracing using the Create 
beam tool. 

1. Double-click the Create beam icon. Create brace 

2. Load the BRACING_V properties. 

3. Enter RHS200*120*8 as the profile. 

4. Change the Position / At depth to: Front and add a 5 mm offset, click Apply. 

 

5. Create one brace using the column top positions at C-1 and C-2. 

 

6. Move the brace 1300 mm downwards and to the middle of the column. 
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1. Select the brace and use Copy > Translate… to copy the brace five times at 6000 mm 
along grid line C. 

Copy the brace 
along grid C 

2. Select all the braces on grid line C and select Copy > Translate… Copy the braces 
to grid line F 

3. In the grid 1 view, pick the outer corner of the column on grid line C as the first 
position. 

 

4. Pick the inner corner of the column on grid line F as the second position, click Copy. 
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Crane Girders 
Next we will add crane girders to the framing. 

1. Double-click the Create beam icon. Create girder 

2. Load the BEAM properties. 

3. Enter IPE450 for the profile size. 

4. In the GRID 1 view pick the grid intersection C-15500. 

5. Use the cursor to snap (Do not pick!!) in the Y direction. 

6. With the keyboard type 930 for the numeric location and press Enter. 

 

1. Copy the girder that you created to other columns on grid line C. Copy girders 

2. Use the Copy – mirror command to copy the girders from grid line C to gridline F. 
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The BasicModel2 model is now complete. 

Save the model. Save the model 

1. Click File > Save as… Save the model 
with a new name 

2. Click after the path C:\TeklaStructuresModels, in the field at the bottom of the dialog 
box and type \BasicModelCombined. 

3. Press the OK button. The model has now been saved with the new name. 

1.5 Combine Models 1&2 
Next we will combine BasicModel1 and BasicModelCombined by copying the objects in 
phase 1 from BasicModel1. To copy the objects from another model we will use the 
command; Copy from model. This command copies objects from specified phase(s) from 
another model. 

To be able to manage the objects from the two models after we have combined them we will 
first transfer the model 2 parts a different phase. 

Help: Modeling > Settings and tools > Settings > Phases 

Change the Phase of BasicModel2 Members, Preparation 
1. Click Properties > Phase number... to open the Phase manager dialog box. Check objects by 

phases 
By default only Phase 1 appears in the dialog box. 

2. Select Phase 1. 

3. Click Objects by phases. 
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All the parts in the model will become highlighted, indicating they belong to Phase 1. 

4. Click Add button to add a new phase. Add a new phase 
– Model2 

5. Edit the name of the new phase to Model 2. 

 

6.  Also edit the name of the Phase 1 to Model 1. 

7.  See that all of the parts are still highlighted in the Model 2 phase. 

8. Click Modify phase. 

9. Now all of the parts in the model have changed to Phase number 2. 

In the BasicModel1 the column footings on gridline B were dimensioned both for steel 
columns on gridline B and concrete columns on gridline C. After combining the models the 
footings on gridline C will no longer be needed and you can delete them. 

Delete the pad footings from grid line C. Remove the pad 
footing 

Edit > Copy from Model 
Since we did not edit the phases in BasicModel1 they all belong to phase number 1. 

1. Click Edit > Copy > From model... Copy from model 

2. Select the BasicModel1 as the model to copy from in the Model directories list. 

3. Enter 1 as the phase number from which to copy the objects. 

4. Click Copy. 
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The model 1 parts will now in the combined model. 

 

 

With the Copy > From model command you are not able to import drawings 
with the model. 

 

Change the Model 1 Part Properties and Numbering Series 
The Model 1 parts were created without paying attention to part properties and they are not 
consistent with the Model 2 parts (color, name, numbering series, and material). 
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The different numbering series and material would result otherwise equal parts getting 
different numbers when numbering. 

In this combined model we want all of the parts to be numbered according to the numbering 
series shown in the table in the beginning of the lesson. To achieve this we will need to 
modify the Model 1 part properties so that they are consistent with the Model 2 parts. 

The properties of the connection parts to be created in the new model will be consistent with 
the existing ones since we used same default Preferences in both models. 

1. Select the Model 1 pad footings. Change Pad 
footing properties 

You can try the available select filters for selecting the footings. 

2. Load the FOOTING properties. 

3. Remove the modify switches and check only Name, Material, Class and Numbering 
series switches. 
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4. Click Modify. 

By following the procedure above change the properties for: Change other 
parts properties 

• Beams 

• Concrete beams 

• Columns 

• Concrete columns 

• Slabs 

• Hollowcore slabs 

• Horizontal bracing 

• Vertical Bracing 

• Silos 

1.6 Define Your Own Select Filters 
To make the selecting of parts easier in the future we will now define select filters for each 
part type. We will use the name of the part as the filtering criteria. 

For steel/concrete beams and columns we will add also the material as the filtering criteria to 
be able to filter them separately. 

Help: Modeling > Settings and tools > Filter > Select filter 

1. Click the Display select filter dialog icon to open the Select filter dialog box. Define select filter 
for footing 

 

2. Load the standard filter to turn out all the possible filtering. 

3. Enter name FOOTING in the Name field of Parts tab. 

4. Enter name FOOTING in the Save as field and click Save as. 

You can now choose the new filter from the drop down list. 
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By following the procedure above define select filters for: 

• Slabs 

• Hollowcore slabs 

• Horizontal bracing 

• Vertical Bracing 

• Silos 

• Rafters 

• Purlins 

To define select filters for plates created both manually and by the connections: Define Select filter 
for plates 

1. Enter name *PLATE* in the Name field of Parts tab. 

(*PLATE* matches all parts of which name includes word PLATE) 

2. Enter name PLATE in the Save as field and click Save as 

To define select filters for Steel Beams: Define Select filter 
for steel beams 

3. Enter the name BEAM in the Name field of Parts tab. 

4. Enter S* in the Material field of Parts tab. 

(S* matches all materials with a material name that begins with the characters S) 

5. Enter name BEAM_STEEL in the Save as field and click Save as. 

By following the procedure above define select filters for: 

• Concrete beams 

• Steel columns 

• Concrete columns 
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Create your own select filters to use both when modeling and using wizards to 
automate drawing creation. 

 
Copy from model command only copies the objects from another model (not e.g. attributes 
from the model folder). We will now bring the attributes created in Basicmodel 1 to 
BasicModelCombined. 

1. Tools > Open model folder. Bring the 
BasicModel1 
attributes 2. Browse to model BasicModel1 > Attributes. 

3. Copy the files. 

4. Browse to BasicModelCombined > Attributes. 

5. Paste. 

 

Finally save the model. Save the model 
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