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1 Basic Modeling 

We will go through the basic functions of Tekla Structures: How to create a new structural 
3D model, how to create grids (i.e. module lines), grid views and structural members in the 
model. As a result of this lesson the model will look as shown below. 

In this lesson 

 

1.1 Starting Tekla Structures 
To start Tekla Structures, click the Windows Start button. Navigate through Programs > 
Tekla Structures > Singleuser > Tekla Structures enu Europe. This will start Tekla 
Structures in European environment using English language. 

Starting Tekla 
Structures 
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The modeling user interface is now opened. At first, most of the menu options and all the 
icons are gray indicating that they are inactive. When you open an existing model or create a 
new model, the icons and available menu options become active. 

 

1.2 Create a New Model – BasicModel1 
To start a new model, you first need to create an empty model database with a unique name. 
In this lesson use the name BasicModel1. 

1. Select File > New… from the pull-down menu or click the New model icon in the 
Standard toolbar to open the New model dialog box. 

Start a new model 

 

2. At the lower left corner of the dialog box, Tekla Structures suggests the name New 
Model for the model. The full path of the model folder is shown in this field. 
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3. Click after the folder path, for example C:\TeklaStructuresModels\ and replace the 
New Model name by BasicModel1. Accept the default option of Tekla Structures to 
Create default view and grid. 

 

4. Click the OK button to create the new model. 

The menus and icons become activated and the model name appears in the title bar of the 
Tekla Structures window. 

 

Every model must have a unique name. Tekla Structures does not 
allow duplicate model names. Do not use special marks ( / \ ; : | ) in 
model names. 

 

 

You can only have one model open at a time. If you already have a 
model open, Tekla Structures prompts you to save that model. 

 

As we had the Create default view and grid checkbox selected, Tekla Structures 
automatically created a grid and a view according to the saved standard view properties. The 
default 3D view and grid are shown below. 
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Cyan dash-and-dot lines show the projections of the grids which are visible on the view 
plane. Tekla Structures indicates the work area of a view using green, dashed lines. For more 
information, see: Help: Modeling > Getting started > Basics. 

To save the model: Save the model 

Select File > Save from the pull-down menu or click the Save icon in the Standard 
toolbar. 

 

 

Remember to save your model every now and then, and always 
when opening another model or exiting Tekla Structures. 

 

Tekla Structures includes also an auto save feature that backs up and saves your work 
automatically at set intervals. These are set in the Autosave properties dialog box obtained 
from the Setup > Autosave… pull-down menu. 

For more information on saving and auto saving, see: 

Help: Modeling > Getting started > Saving a model and exiting Tekla Structures 

Most commands of Tekla Structures are found both in menus (main or pop-up) and in 
toolbars (icons). In this training manual we will mainly use the pop-up menu to activate 
commands. 

 

There are several ways to execute commands in Tekla Structures: 

• Icons 

• Commands in main pull-down menu 

• Commands in pop-up menu 

By default all the commands are found in pull-down menu, most of 
them in the icons. A pop-up menu appears when you click the right 
mouse button (right-click). If you have an object selected, the 
commands on the pop-up menu relate to that object. 

 

For more information on Tekla Structures screen layout and toolbars, see: 

Help: Modeling > Screen layout 

Help: Modeling > Toolbars 

6 TEKLA STRUCTURES BASIC TRAINING  Copyright © 2004 Tekla Corporation  
 Basic Modeling   
 



1.3 Create Grids 

 

To create the appropriate grid for BasicModel1 as shown above, you can delete the existing 
grid and create a new one from the Points > Grid… pull-down menu. Alternatively you can 
modify the existing grid. 

To modify the existing grid: Modify the 
existing grid 

1. Double click the grid line. 

2. Complete the appearing Grid dialog box as shown below by filling in the X, Y and Z 
coordinates and the labels for the grid lines. 

 

3. Click Modify to apply the new grid values. 

4. Enter the grid file name, GRID1, and click the Save as button to save the grid values for 
later use. The file GRID1.grd appears in the attributes subfolder of your model folder. 

For more information on grids and dialog box buttons, see: 

Help: Modeling > Introduction > Inputting information > Common buttons 

 

The number of decimals used in the Grid dialog box (as well as in 
other modeling dialog boxes) can be controlled from the Units and 
decimals... dialog box obtained from the Setup pull-down menu. 
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When the grid was modified, the work area of the view, shown with the green dashed line, 
was not updated. 

To fit the work area according to the modified grid: Fit work area 

1. Click the view. 

2. Right-click and select Fit work area from the pop-up menu. 

 

The view should now look as shown below: 

 

1.4 Create Plane Views Along Grid Lines 
We will now create Elevation and Plan views along the grid lines created in the previous 
section. 

A view is a representation of a model from a specific location. Each view is displayed in its 
own window inside the Tekla Structures window. Each view has a view plane on which the 
grids are visible and points are represented as yellow crosses. Points outside the view plane 
appear as red dots. 

For more information, see: Help: Modeling > Getting started > Views. 

To create views along grid lines, Create grid views 

1. Select one grid line. 

2. Right-click and select Create view > Grid views from the pop-up menu to open the 
Creation of views along grid lines dialog box. 
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3. Click the Show… button of the XY view plane to open the View properties dialog box. 

4. Change the Angle and View depth values as shown below and click OK to close the 
dialog box. 

 

5. Select the number of views as All and click Create in the Creation of views along grid 
lines dialog box. 

The Views dialog box appears presenting all the created views. All invisible named views 
are listed on the left, and all visible views on the right. 
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For more information on view properties, see: 

Help: Modeling > Getting started > Views > View properties 

To display or hide views: Display or hide 
views 

1. Click the Open named view list icon to open the Views dialog box (which is now 
already open). 

 

2. Select the view(s) you want to display or hide. 

3. Use the arrows to move view(s) from left to right (visible) or vice versa (invisible). 
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Do not keep too many views open at the same time. Nine is the 
maximum number of open views. You can open or close named 
views by clicking the Open named view list icon. Delete 
unnecessary views from the view list. 

To switch between views, press Ctrl+Tab. 

 

You can rotate the model in a 3D view with rendered view type. Rotate the model 

1. Press the key V. 

2. In the view, pick a center of rotation. 

3. Hold down the Ctrl key, and click and drag with the middle mouse button. 

With the shortcut Ctrl+P you can change the view angle between 3D and Plane, which is 
very useful. 

Change between 
3D / Plane 

 

 

1.5 Create Foundations 
We will now create foundations for the BasicModel1. 
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Column Footing 
To create footings for columns: 1800*1800 footing 

1. Double-click the Create pad footing icon. This will open Pad footing properties 
dialog box 

 

2. Complete the Pad footing properties dialog box as shown and click Apply. 

 

3. In the 3d view, pick the intersection of grids A-1 to create the footing. 

4. Create the rest of the 1800*1800 footings at other intersections of grid line A by picking 
each position. 

Help: Part position 

Help: Profile library / Parametric 
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You can undo (and redo) previous commands one by one since the 
last save by clicking the icons shown or typing Ctrl + Z (Undo) and 
Ctrl + Y (Redo). 

 

While still in the command, 2700*2700 footing 

5. Complete the Pad footing properties dialog box for 2700*2700 footing as shown and 
Apply this. 

The footings on grid B need offsetting from the grid line because there will be additional 
columns modeled afterwards. This offset will be accomplished by adjusting the Vertical 
Position value in the Pad footing properties dialog box. 

 

6. Create the footings at intersections of the gridline B. 

7. Right click and select Interrupt to end the command. 

 

The commands will stay on until you interrupt them. 

To end commands right-click and select Interrupt from the pop-up 
menu, or press the Esc key. 

To restart the last command used press Enter. 

 

Foundations for Silos – Parametric Profiles 
We will create two identical circular foundations for the silos. At first, one foundation will be 
created at the coordinate 4500,4500,0 and then the other foundation will be created as a copy 
of the first one.  

Tekla Structures contains standard (library), parametric, and user-defined profiles. For the 
foundation, we will use parametric profiles instead of the library profiles. 

Help: Modeling > Parts > Profile 

Help: Modeling > Settings and tools > Appendix A: Parametric Profiles 
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1. Double-click the Create pad footing icon. Create footing 

 

2. Complete the Pad footing properties dialog box as shown and click Apply. 

 

You can select the profile of a part from the Select profile dialog 
box that opens next to the Profile field in the part properties dialog 
box. 

You can as well enter a profile name in the Profile field in the part 
properties dialog box. 
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3. Type 4500,4500 to define the position for the footing (typing the numbers automatically 
displays the Enter a numeric location dialog box). 

 

4. Click Enter, and the foundation is created. 

 

Help: Modeling > Settings and tools > Snapping 

1. Click the footing once to select it. Copy the footing 

2. Right click and select Copy > Translate… from the pop-up menu. Complete the dialog 
box as shown. 
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3. Click Copy. 

 

Now the footings should look like those shown below: 

 

1.6 Create Steel Members 

Columns 
We will first create two of the columns and then use the Copy command to create the other 
columns. 

To create the first two columns: Create columns 

1. Double-click the Create column icon. 

 

2. Complete the Column properties dialog box as shown below, and then click Apply. 
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3. Pick the intersection of grids A-1 to create one column, and then pick grid B-1 to create 
the second column. 

1. Select the columns that you just created by dragging a window across them. Copy columns 

2. Right click and select Copy > Translate… from the pop-up menu. Complete the dialog 
box as shown below and click Copy. 

 

Now all the columns appear in the model. 
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When identical structures appear in the model, you can 
alternatively create one footing (and its reinforcement), the steel 
column on top of it and the base plate connection between the 
footing and the column, and copy this structural entity to all other 
positions of similar structures. 

You can select multiple parts in the model by holding down the 
Ctrl-key and picking objects in the model. 

 

Help: Modeling > Introduction > Selecting model objects > How to select objects 

Silos 
We will now model the silos by using solid parametric profiles. A more precise alternative 
would be to create the silo as a circular hollow section with a contour plate welded on top of 
it. 

1. To create the silos, double-click the Create column icon. Create silos 

 

2. Complete the Column properties dialog box as shown below, and then click Apply. 

 

3. Pick the top point of the first silo footing and then the other. 
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Now the silos appear in the model. 

 

 

The visibility of objects in views depends on the work area, view 
depth, view setup, and view filter. You can also temporarily hide 
parts in a view by using the Hide tool. 

In the pictures hereafter all the model objects created may not 
always be visible. 

Help: Modeling > Getting started > Views > Displaying and 
hiding objects in views 

 

Level 3850 Beams 
We will first create the beams at the +3850 level and then copy them (using the select filter) 
to the two upper levels. 

1. Open the PLAN +3850 view. Create beams 

 

2. Double-click the Create beam icon. 

 

3. Complete the Beam properties dialog box as shown and Apply. 
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4. In the PLAN +3850 view pick intersection of gridlines A-4 and then B-4. 

5. Continue at grid lines 5, 6, and 7. 

 

 

When inputting horizontal members always pick from left to 
right or from bottom to top for consistency purposes. 

 

Copy Beams to Upper Levels 
1. Choose the select filter option beam_filter from the drop down list. Filter beams 

Help: Modeling > Settings and tools > Filter > Select filter 
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2. By dragging the mouse, select an area through the model. 

 

1. In the Grid 7 view right-click and select Copy > Translate… from the pop-up menu. Copy beams 

 

2. Pick the grid line intersection B-3850 and then B-7350. Check the values in the dialog 
box. 

 

3. Click Copy. 

4. Copy beams to level +13400 by repeating steps 3-6. 

5. Change the select filter option back to standard to enable also the selection of other 
objects but beams. 
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Level 13400 Beams 
Next we will create beams at the view +13400 level. 

By using the same beam properties that we applied earlier, create the missing beams at the 
grid intersections shown in the figure below. 

Create grid beams 

 

Next we will create beams in locations where no grid lines intersect. The snapping tools help 
you pick points to position objects precisely without having to know the coordinates or 
layout additional lines or points. 

Create the rest of 
the beams 

Help: Modeling > Settings and tools > Snapping 
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1. Double-click one of the existing beams in the model and press Apply. Create beam A 

2. Start the beam command. 

3. Make sure only the Snap to reference lines / points icon of the two main snap switches 
on the right is pressed down. 

 

4. Make sure the Snap to mid points icon is pressed down. 

 

5. Pick a midpoint of the beam between grid A-2 and A-3 and then the midpoint of the 
beam between grid B-2 and B-3. 
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We will pick the start position of beam B by using the grid intersection A-1 as a temporary 
reference point and tracking along grid 1 to the intersection B-1 direction for 9000 units. 

Create beam B 

 We will then pick the second position of beam B using the temporary snap switch 
Perpendicular. 

1. Start the beam command. Pick the first 
position of beam 
B 2. Hold down the Ctrl key and pick grid intersection A-1 as the origin to show the “From” 

location coordinates. 

3. Then use the cursor to snap (Do not pick!!) in the correct direction (e.g. to grid 
intersection B-1). 

 

4. Type 9000 for the numeric location. (Enter a numeric location dialog box will open 
automatically). 

 

5. Press Enter and the cursor snaps to the correct position. (=9000 mm from A-1 in the 
direction of B-1). 

6. Right click and select Perpendicular. Pick second 
position of beam 
B 

 

7. Pick the 2nd position on beam A (see below). 
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While still in the beam command, Create beam C 

8. Right click and select Intersection for snap override. 

 

9. Pick the intersection of beam B and grid 2 and then the intersection of grid B-2. 

 

We will first create one of the beams that frame around the silo and then by using the Copy > 
Rotate command create the other three. 

Create beam D 

Help: Modeling > Settings and tools Settings and tools reference > Edit > Copy > rotate 

1. Hold down the Ctrl key and pick grid intersection A-1 to show the “From” location 
coordinates, use the cursor to snap (Do not pick!!) in the correct direction. (E.g. grid 
intersection B-1). 

2. Type 4000 for the numeric location and press Enter, the cursor snaps to the correct 
position. 
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3. Press the letter O on the keyboard, to snap to positions in orthogonal directions on the 
work plane (0, 45, 90, 135, and 180 degrees). 

4. Let the cursor to snap to the midpoint as shown below and pick. 

5. Press the letter O to turn the ortho off. 

 

1. Select the beam that you just created. Copy rotate the 
beam 

2. Right click and select Copy > Rotate… from the pop-up menu. 

 

3. Pick the center point of the silo as the point to define the rotation (select a view in which 
the silos are visible and pick near the circumference to snap to the center point). The 
origin X0 and Y0 values will appear in the dialog box. 

4. Complete the other fields in the dialog. 

5. Click Copy. 
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We will now copy the beams to the other silo. Copy translate the 
beam to the other 
silo 1. Select the beams shown highlighted in the picture (press the Ctrl key to add parts to the 

selection). 

2. Copy > translate… them 9000 mm in the x direction. 

 

Bracing 
Working in the Grid A elevation view, we will input the vertical bracing members using the 
Create beam tool. 

 

1. Double-click the Create beam icon. Create braces a 
and b 

2. Complete the Beam properties dialog box as shown and Apply. 
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3. In the 3d view create brace a by first picking the grid intersection A-2 and then the 
midpoint of column A-3. 

 

4. Create brace b by picking the top position of column A-2 and then midpoint of column 
A-3.  
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We can see from the drawing above that the lower end of the brace needs 200 mm offsetting 
from the grid. Now we will use the handles to move the part end. 

Use handle to 
move brace end 

Help: Handles 

1. Select brace a to display the handles. 

 

2. Pick the yellow handle (Tekla Structures then highlights the handle). 

3. Right click and select Move > Translate… to move the handle 200 mm upwards. 

4. Click Move. 

5. Repeat the procedure to move brace b’s top handle 800 mm downwards. 

1. Select braces a and b. Copy mirror 
braces a and b 

2. Right click and select Copy > Mirror… 

3. In the 3d view, pick grid A-3 then grid B-3 to define the mirror line. 

4. Click Copy. 
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Help: Copy > Mirror 

Now we have modeled all the steel members in Model1. The model should look like in the 
figure below. 
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1.7 Create Concrete Members 

 

Concrete Hollow Core Slabs 
We will now create concrete hollow core slabs. Instead of positioning the slabs to the grid 
line intersection we will model the slabs to the face of the steel columns. 

In the PLAN +13400 view: Create hollow 
core slabs 

1. Double-click on the Create concrete beam icon. 

 

2. Complete the Concrete beam properties dialog box as shown and Apply. 

 Copyright © 2004 Tekla Corporation TEKLA STRUCTURES BASIC TRAINING  31 
  Basic Modeling  
 



 

3. Pick the intersection of the column flange outer face and gridline 4 then intersection the 
column flange outer face and grid line5 (be sure that the Snap to geometry lines/points 
is pressed). 

4. Click the middle mouse button to create the slab. 

 

 

1. Select the slab that you just created. Copy the slabs in 
Y direction 

2. Right click and select Copy > Translate… from the pop-up menu. 

3. Type 1200 in the dY field of the Copy – translate dialog box and 10 as the number of 
copies. 

1. Drag an area select, choosing all the concrete slabs. Copy the slabs in 
X direction 
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2. Right click and select Copy > Translate… from the pop-up menu. 

3. Type 6000 in the dX field of the Copy - translate dialog box. 

 

4. Click Copy. 

Copy Concrete Hollow Core Slabs to Levels 7350 and 3850 
1. Hold down Ctrl key and choose all the hollow core slabs by dragging 3 areas through the 

slabs. 
Copy the slabs 

 

2. Still holding down Ctrl key pick the two slabs shown in the picture below to unselect 
them (we will create stairs here in a later chapter). 

 

3. Right click and select Copy > Translate… from the pop-up menu. 
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4. Enter -6050 in the dZ field of the Copy – translate dialog box, click Copy. 

5. Enter -9550 in the dZ field of the Copy – translate dialog box, click Copy. 

 

Concrete Slab 

 

1. Double-click the Create concrete slab icon. Start the slab 
command 

2. Complete the Concrete slab properties dialog box as shown and Apply. 
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3. In the PLAN +13400 view pick point A (intersection of column flange outer face and 
gridline 1, shown in the previous figure). 

Pick positions for 
the slab 

 

 

4. Let the cursor snap to position just picked (do not pick!) and press Y to lock the Y 
coordinate. 
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5. Let the cursor now to snap to the end point of beam near point B and pick. 

 

6. Press Y to release the coordinate lock. 

 

7. Pick point C. 

 

8. Pick point D. 
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9. Click middle button to create the slab. 

 

1. Select the slab that you just created. Copy concrete 
slab 

2. Copy translate the slab 9000 mm in X direction. 

Now the Model1 framework is finished. 

 

Links to additional information 
Help: Modeling > Introduction > General informationSingle user mode vs. multiuser 
mode 

Help: Modeling > Introduction > General information > Languages and environments 
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